Investigating Performance issues
Incident Report for Totango
Resolved
We've identified the malfunctioning component and have restored service fully.
We'll continue to monitor the situation.
Posted Jul 19, 2017 - 19:38 UTC
Investigating
We are investigating performance issues reported by some of our clients. This can be due to slow query load times or delay in processing of incoming data. We'll continue to update on our progress.
Posted Jul 19, 2017 - 18:31 UTC