Campaigns page not loading consistently
Incident Report for Totango
Resolved
Campaign service availability has been restored, apologies for the inconvience.
Posted 9 days ago. Dec 03, 2018 - 09:57 UTC
Investigating
We currently investigating indications that the campaigns page is alternately not loading with data.
Posted 9 days ago. Dec 03, 2018 - 09:38 UTC
This incident affected: Campaigns.