Degraded performance due to email provider
Incident Report for Totango
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 21:50 UTC
Monitoring
The email provider has fixed the issue and currently monitoring the system performance.
Posted Jul 28, 2020 - 19:43 UTC
Identified
The email provider has identified the root cause and working on resolving the issue.
Posted Jul 28, 2020 - 19:20 UTC
Investigating
Our email provider is reporting issues, customers may be experiencing issues with mail and statistics delay and signups.
We will provide an additional update as soon as possible.
Posted Jul 28, 2020 - 15:39 UTC
This incident affected: Campaigns and Email to Touchpoints.