Monitoring Issues with connecting the application
Incident Report for Totango
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 16, 2019 - 15:42 UTC
Monitoring
We're monitoring the temporary outages reported in the last couple of hours, apologies for the inconvience.
Posted 6 months ago. Jan 16, 2019 - 09:18 UTC
This incident affected: Totango Web Application.