EU Data Center - Application performance issues
Incident Report for Totango
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 19, 2018 - 03:22 UTC
Investigating
We are currently investigating performance issues with loading certain pages in application,
The engineering team is working on restoring the service with the highest priority.
Posted 7 months ago. Dec 19, 2018 - 02:36 UTC
This incident affected: Totango Web Application.