Issue identified in the Email-to-Touchpoint feature
Incident Report for Totango
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 07:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 10, 2024 - 19:12 UTC
Investigating
We are currently investigating this issue.
Posted Oct 10, 2024 - 17:10 UTC
This incident affected: Email to Touchpoints.