Delay in campaign email send in our US site
Incident Report for Totango
Postmortem

Event Description:
A delay in campaign delivery was noted for our US services.

Root Cause:
Our third-party email delivery service experienced a temporary outage starting at 7am GMT which caused time-based campaign deliveries to be delayed. After working with the provider, we saw a restoration of service around 5pm GMT which allowed our systems to return normal operations.

Preventive actions:

  • We will be working with our provider to better understand the cause for the outage and work with them on ensuring it does not impact our clients moving forward.
Posted Feb 14, 2023 - 14:06 UTC

Resolved
The issue with the campaigns in the US has been resolved.
Posted Feb 14, 2023 - 09:12 UTC
Monitoring
Our third party provider has resolved the issues with mail delivery and we are currently monitoring as the systems begin to catch up. We apologize for the inconvenience this may have caused.
Posted Feb 13, 2023 - 18:39 UTC
Update
We are continuing to work on a fix for a delay in the following components:
1. Sending Emails from campaigns.
2. Inviting users via Touchpoints.
3. Replying to Touchpoints via email.

Please note that our third party is receiving these messages, we do not expect any data loss.
Once the issue is resolved, we expect all messages to be delivered
Posted Feb 13, 2023 - 10:05 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 13, 2023 - 08:44 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 13, 2023 - 08:44 UTC
Update
We are continuing to work on a fix for this issue.
Posted Feb 13, 2023 - 08:26 UTC
Identified
Due to third party issues we are not able to send campaigns in our US site.
We are working with their support to resolve this issue as soon as possible.
Posted Feb 13, 2023 - 08:25 UTC
This incident affected: Campaigns.