Degraded performance

Incident Report for Totango

Resolved

This incident has been resolved.
Posted Jan 02, 2020 - 19:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 02, 2020 - 16:12 UTC

Investigating

We are currently investigating issues with loading pages in Totango application and are working to resolve the issue as soon as possible.
Thank you for your patience while we’re looking into it.
Posted Jan 02, 2020 - 15:46 UTC
This incident affected: Totango Web Application.