Customer Data hub not loading
Incident Report for Totango
Resolved
This incident has been resolved.
Posted Apr 02, 2023 - 18:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 02, 2023 - 17:59 UTC
Identified
The issue has been identified and a fix is being implemented
Posted Apr 02, 2023 - 14:52 UTC
Investigating
We are currently investigating an issue related to Customer Data hub, we expect loading issues and upload returning an error.
Posted Apr 02, 2023 - 12:48 UTC