Status on Ukraine
Incident Report for Totango
Resolved
This incident has been resolved.
Posted Jul 22, 2022 - 12:56 UTC
Monitoring
As the world watches Russia’s full-scale invasion of Ukraine, Totango is sending wishes for the safety of the Ukrainian people and hope for peace in the region. We are in contact with our team located in the country, who remain safe, at this time.
While we continue to monitor the situation abroad, Totango does not anticipate any disruption to our services, support, or development.
Posted Feb 25, 2022 - 22:10 UTC