Degraded performance
Incident Report for Totango
Resolved
The incident has been resolved.
Posted Dec 03, 2019 - 16:12 UTC
Update
We are continuing to investigate this issue.
Posted Dec 03, 2019 - 15:25 UTC
Investigating
We are currently investigating issues with loading pages in Totango application and are working to
restore service.
Thank you for your patience while we’re looking into it.
Posted Dec 03, 2019 - 15:24 UTC
This incident affected: Totango Web Application.