Issues with Account Assignment

Incident Report for Totango

Resolved

This incident has been resolved.
Posted Apr 16, 2024 - 11:55 UTC

Monitoring

A fix was identified and the team is monitoring results.
Posted Apr 15, 2024 - 21:51 UTC

Investigating

We have identified issues related to Account assignment misalignment and are actively investigating.
Posted Apr 15, 2024 - 15:45 UTC
This incident affected: Totango Web Application.