Degraded Performance
Incident Report for Totango
Resolved
This incident with slow performance has been resolved.
Posted Apr 06, 2022 - 07:00 UTC
Monitoring
A fix has been implemented and we are monitoring the system. Please help refresh the browser if any slow response issue is experienced.
Posted Apr 05, 2022 - 20:26 UTC
This incident affected: Totango Web Application.