Issue with Outlook's Touchpoint Connect
Incident Report for Totango
Resolved
The issue has been resolved.
Posted Oct 27, 2024 - 14:52 UTC
Investigating
We are currently investigating an issue within Outlook's Touchpoint Connect.
Email-To-Touchpoint without the Outlook connect should be working as expected.
Posted Oct 27, 2024 - 14:27 UTC
This incident affected: Email to Touchpoints.