Campaign Service Performance
Incident Report for Totango
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 22, 2019 - 23:23 UTC
Investigating
We are currently investigating the issue
Posted 3 months ago. Jan 22, 2019 - 21:46 UTC
This incident affected: Campaigns.