Loading issues with Account profile

Incident Report for Totango

Resolved

This incident has been resolved.
Posted Oct 03, 2021 - 10:25 UTC

Investigating

We are currently investigating intermittent issues with loading account profile, we are working to resolve the issue with the highest priority.
Thank you for your patience while we’re looking into it.
Posted Oct 03, 2021 - 10:06 UTC
This incident affected: Totango Web Application.