Issues with editing Tasks and Touchpoints
Incident Report for Totango
Resolved
Tasks service availability has been restored and all affected application areas should be
operational.
Posted 3 months ago. Nov 27, 2018 - 13:22 UTC
Investigating
We are currently investigating an incident with our tasks service, Causing inconsistent behaviour with tasks and touchpoints adding/ editing.

We are working to restore tasks availability and will update shortly about our progress, Thank you for your patience while we look into it.
Posted 3 months ago. Nov 27, 2018 - 11:55 UTC
This incident affected: Totango US (Totango Web Application, Tasks and SuccessPlays).