Email Sending Issues
Incident Report for Totango
Resolved
This incident has been resolved. Thank you for your patience.
Posted Sep 12, 2024 - 14:52 UTC
Investigating
We are currently experiencing an issue with email sending from Totango. This issue is affecting all campaigns and other emails, and no emails are being sent at this time.

Our team is actively investigating the issue, and we will provide updates as soon as we have more information.
Posted Sep 12, 2024 - 14:35 UTC
This incident affected: Campaigns and Email to Touchpoints.